you are viewing a single comment's thread.

view the rest of the comments →

[–]d3rr 4 insightful - 1 fun4 insightful - 0 fun5 insightful - 1 fun -  (11 children)

Hello! Thanks for the kind words.

Yes you must currently install the test data or required stuff will be missing. There's an improvement in the works.

All of the missing cron jobs are present in the cron file, you don't have to worry about that. You may wish to enable some jobs listed there that are currently disabled.

I have no idea how that popular subreddits works... We have that cron job disabled. For now I think you can ignore that service failing or set it to disabled. Same with trending.

Anyway the README file of our repo is the most up to date and authoritative setup guide.

[–]portcity[S] 3 insightful - 1 fun3 insightful - 0 fun4 insightful - 1 fun -  (10 children)

Thanks so much! I just read that y'all moved your servers to Switzerland (I'm guessing because you had the DMCA takedown?). I set up my server in Buffalo because my host offered free DDOS protection, but I'm thinking maybe I should go ahead and move my server to Europe before I ramp this thing up ....

[–]d3rr 3 insightful - 1 fun3 insightful - 0 fun4 insightful - 1 fun -  (9 children)

I think we're worried about political censorship moreso than DMCA.. I donno. We're still at risk of DMCA. It all depends on what kind of content you envision. Finding a Ubuntu 14 host is a victory in itself.

Anyway I'm happy to support SaidIt and Reddit clones into the future. If you are planning on taking the site live, you've gotta review the 'Production Config' section of the README. I also have a huge web server optimization that's not listed there but will be soon.

[–]portcity[S] 3 insightful - 1 fun3 insightful - 0 fun4 insightful - 1 fun -  (8 children)

If anyone reading this wants to know where I found the Ubuntu 14.04 server, I found it at Virmach.com, which I was already using for other ... ah censorship-resistant related activities (lol). I would definitely be interested in the web server optimization section, and yeah, I'm going to be taking the site live pretty much immediately. One other question I have is this: my SSL appears to be broken, but I checked with my domain registrar and the rep told me that the links & images from the reddit test data is what broke my SSL (ie there's a broken SSL somewhere in the test data). However when I reinstalled with no test data, the SSL is already broken, before any test data is installed. Any thoughts on that?

[–]d3rr 3 insightful - 1 fun3 insightful - 0 fun4 insightful - 1 fun -  (0 children)

Out of the box it comes with a self-signed SSL cert (for reddit.local) which will always generate a security warning. Maybe that's what you mean by broken.

I recommend you get a free cert from Let's Encrypt / certbot, and use the DNS method to verify you control your domain. It's 5x easier than using the 'http' verification or whatever the other one is called.

Then you just need to update your nginx file accordingly and change the domain name in multiple Reddit configs if you haven't already.

[–]d3rr 3 insightful - 1 fun3 insightful - 0 fun4 insightful - 1 fun -  (6 children)

And yes, the thumbnail paths are unfortunately in the database with their domain name, so you need a postgres query to update those if you change the domain.

[–]portcity[S] 3 insightful - 1 fun3 insightful - 0 fun4 insightful - 1 fun -  (5 children)

I actually changed the domain name to my domain name before I ran the install, so I think all that is ok. I did this: REDDIT_DOMAIN=yourdomain.com ./install-reddit.sh Now I'm working on the certbot ...

[–]d3rr 2 insightful - 1 fun2 insightful - 0 fun3 insightful - 1 fun -  (4 children)

Good stuff man, that's the way to do it. I should test that flow sometime :)

[–]portcity[S] 3 insightful - 1 fun3 insightful - 0 fun4 insightful - 1 fun -  (3 children)

Miss :) So I just tested the SSL at the SSL Lab and the domain name http://portcity.online (the cheapest temp domain name I could find till i figure out a good one) got an A rating but the actual IP address failed the test, saying Warning: Inconsistent server setup. Now I need to dig around in the DNS records between the domain and the IP and figure out where I did something wrong ...

[–]magnora7 1 insightful - 1 fun1 insightful - 0 fun2 insightful - 1 fun -  (2 children)

Nice I made a post: https://portcity.online/s/Introductions/comments/1/test_post/

Funny when you created the new batch of test data, it actually added data to my existing account! It added a bunch of posts and votes by magnora7 but I didn't make them. Must be a little bug in the test-data code. Funny

[–]portcity[S] 3 insightful - 1 fun3 insightful - 0 fun4 insightful - 1 fun -  (1 child)

Lol, sorry. You know I didn't do that. I was literally out on a walk by the beach. But even if the test data code does have a bug, it doesn't matter right? Because presumably I and whoever uses it will eventually delete and filter all of it out. Thanks so much for testing it! Now I just have to fix this darn SSL problem and [everything else I have to do]. I really can't overstate how much I appreciate what you guys have done. Hopefully if I document my efforts here (and solves I find) it will help others who google and find my posts to install their instances.