you are viewing a single comment's thread.

view the rest of the comments →

[–]d3rr 1 insightful - 1 fun1 insightful - 0 fun2 insightful - 1 fun -  (13 children)

It's possible that you are getting a new permission denied error, but let's make sure this .lounge folder gets squared away. Did you get the permissions changed there? From your last comment, yes, root owns all of it.

We need this to not say root at all:

 ls -la /home/chatuser/.lounge

It's not a big deal if you just want to run this as user 'reddit'.

[–]portcity[S] 1 insightful - 1 fun1 insightful - 0 fun2 insightful - 1 fun -  (12 children)

ls -la /home/chatuser/.lounge

I'm not totally sure how to read this. Also, my formatting gets removed so it makes it harder for you to read this:

chatuser@redditclone:~/lounge-autoconnect$ ls -la /home/chatuser/.lounge total 24 drwx------ 4 chatuser root 4096 Jul 21 03:36 . drwxr-xr-x 10 chatuser chatuser 4096 Jul 21 03:01 .. -rw-r--r-- 1 chatuser root 7801 Jul 21 03:42 config.js drwxr-xr-x 2 chatuser root 4096 Jul 21 00:37 storage drwxr-xr-x 2 chatuser root 4096 Jul 21 03:44 users

[–]d3rr 1 insightful - 1 fun1 insightful - 0 fun2 insightful - 1 fun -  (11 children)

Well if you go the 'reddit' user route, you'd need to reinstall TheLounge. On comments here, you can indent with 4 spaces if you want to make it monospaced code style.

Anway.... lets do

$ sudo chown -R chatuser:chatuser /home/chatuser/.lounge

And then try to start TheLounge again, then give me the output. You could also delete /home/chatuser/.lounge and /home/chatuser/lounge-autoconnect and start over and be careful not to run anything as root.

[–]portcity[S] 1 insightful - 1 fun1 insightful - 0 fun2 insightful - 1 fun -  (10 children)

Ok I did everything all over again, installing The Lounge in user: reddit, and I got the exact same permission denied problem (see the results of ls -la in this pastebin: https://pastebin.com/3efUw36U The only thing I haven't done is I haven't updated the certificate so that the Lounge certificate is the same as the Unrealircd cerfificate (because I've been following the instructions to the letter and the instructions say to use the certificate with the word "snakeoil" in it.

I also installed Node and curl on user:reddit.

I'm also not totally sure how to remove installed packages? I know about rm -rf but that didn't seem to work on removing the lounge from chatuser. Like maybe I don't know the exact paths?

[–]d3rr 1 insightful - 1 fun1 insightful - 0 fun2 insightful - 1 fun -  (9 children)

try:

$ cd ~/lounge-autoconnect
$ touch thelounge.log

Aka make sure thelounge.log exists and isn't owned by root.

With removing TheLounge, it wasn't really installed like a proper unix app, so to removing it is just this afaik:

$ sudo rm -rf /home/chatuser/.lounge
$ sudo rm -rf /home/chatuser/lounge-autoconnect

[–]portcity[S] 1 insightful - 1 fun1 insightful - 0 fun2 insightful - 1 fun -  (8 children)

cd ~/lounge-autoconnect

reddit@redditclone:~$ cd ~/lounge-autoconnect
reddit@redditclone:~/lounge-autoconnect$ touch thelounge.log
touch: cannot touch ‘thelounge.log’: Permission denied

Ok, I used those commands above to remove the lounge from user: chatuser.

[–]d3rr 1 insightful - 1 fun1 insightful - 0 fun2 insightful - 1 fun -  (7 children)

touch: cannot touch ‘thelounge.log’: Permission denied

It sounds like your TheLounge folder isn't owned by you?

$ ls -la ~/lounge-autoconnect

[–]portcity[S] 1 insightful - 1 fun1 insightful - 0 fun2 insightful - 1 fun -  (6 children)

ls -la ~/lounge-autoconnect

Yup: https://pastebin.com/zA0ni0EM

[–]d3rr 1 insightful - 1 fun1 insightful - 0 fun2 insightful - 1 fun -  (5 children)

Yeah your whole directory is owned by root. You should not be doing a sudo git clone, just a git clone, so user reddit owns it all. I'd delete it and re-do it.

[–]portcity[S] 2 insightful - 1 fun2 insightful - 0 fun3 insightful - 1 fun -  (4 children)

You nailed it. I had gotten into the habit of always putting "sudo" in front of every command because I was getting a lot of "permission denied" if I didn't do that, so yes, I did put "sudo git" while installing that git clone. So I just reinstalled the lounge, and it seemed to work.

Where I'm at now: when I load https://portcity.online, it works ... but when I load the "unsafe scripts" it breaks the SSL and reverts back to http ... that loads the box on the right (which I think is the IRC client?) but it's blank and it says "reddit.local's IP address could not be found." I am positive I edited /etc/hosts to have my VPS IP point to reddit.local